Web Hosting
Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2006
    Posts
    1

    Default ** PLEASE HELP ** Mediawiki -> Database name & username problems

    I'm a newbie trying to get my mediawiki site up but so far have not been able to get past probably a very simple problem.

    When filling out the mediawiki setup information it asks:

    Database Name ->
    DB Username ->
    DB Password ->
    DB Password (confirm) ->

    In the installation instructions, it says that I need to use my cpanel username then underscore (_) the database name.

    It then says that the same rules apply to DB username.

    Ok, I've tried every variation I can think of and it keeps rejecting my username & password.

    Assuming these are the variables:

    cpanelusername = cpanel username (my logon name to cpanel)
    databasename = the MySQL database name
    dbusername = database username that I created inside MySQL database

    My reading of the tutorial indicates that:

    Database Name -> cpanelusername_databasename
    DB Username -> cpanelusername_dbusername
    DB Password -> password created for dbusername
    DB Password (confirm) -> same as above

    Again, I've tried tons of variations and none seem to work. The error message I get is:

    Attempting to connect to.................failed due to authentication errors. Check passwords.

    Then in red letters next to my username and password, it says check username and password.

    Any help would be GREATLY appreciated

    Thanks.

  2. #2
    Join Date
    Sep 2006
    Posts
    25

    Default

    Ok, now this one's a little bit tough at first, but I'll try to talk you through it.

    Now in Cpanel (http://yoursite.com:2082) login and head to the MySQL Databases section.

    Create a new database, my suggestion is "wiki" (without quotes).

    Then create a new user, again use "wiki" with all privileges and select a password of your choice, not your Cpanel password!

    After you have created those, assign the username to the database Wiki, it will look like this username_wiki.

    Put in these details as follows:

    DB Name: Username_Wiki
    DB Username: Username_Wiki
    DB Password: ThePasswordThatYouChose.
    Repeat password:"" ""

    Hope this helps.

  3. #3
    Join Date
    Aug 2007
    Posts
    5

    Default

    I appear to be having a similar problem.
    My siteground username is homewor5.
    My mysql database name is wiki.
    My mysql username is wiki.

    In the mediawiki installation:
    my database name is "homewor5_wiki"
    my db username is "homewor5_wiki"
    my password is the same as my cpanel password.

    After I click "install" i get a page with this text:
    * PHP 5.0.5 installed
    * Found database drivers for: MySQL PostgreSQL
    * PHP server API is cgi; using ugly URLs (index.php?title=Page_Title)
    * Have XML / Latin1-UTF-8 conversion support.
    * Session save path (/tmp) appears to be valid.
    * PHP is configured with no memory_limit.
    * Couldn't find Turck MMCache, eAccelerator, or APC. Object caching functions cannot be used.
    * Found GNU diff3: /usr/bin/diff3.
    * Found ImageMagick: /usr/bin/convert; image thumbnailing will be enabled if you enable uploads.
    * Found GD graphics library built-in.
    * Installation directory: /home/homewor5/public_html/mediawiki-1.10.1
    * Script URI path: /mediawiki-1.10.1
    * Environment checked. You can install MediaWiki.
    *

    Generating configuration file...
    * Database type: MySQL
    * Loading class: DatabaseMysql
    * Attempting to connect to database server as homewor5_wiki...success.
    * Connected to 5.0.27-standard-log
    o Error selecting database homewor5_wiki: 1044 Access denied for user 'homewor5_wiki'@'localhost' to database 'homewor5_wiki'

    Now I know you said to use a password different than my cpanel password, but when I do that, I also get the message "omething's not quite right yet; make sure everything below is filled out correctly" and "check username and passage."

    Once again, any help would be greatly appreciated.

    BTW, is the mediawiki script installation by siteground free? Because I know they have a similar service which costs around $50.

  4. #4

    Default

    Quote Originally Posted by wikonfused View Post
    ]
    BTW, is the mediawiki script installation by siteground free? Because I know they have a similar service which costs around $50.
    Yes it is, please see this link:
    http://forum.siteground.com/showthread.php?t=4599

  5. #5
    Dan Guest

    Default

    If you are still experiencing issues with the MediaWiki installed you may post a ticket under the Script Installation > Script Installation category and our Support Team will install the latest version of MediaWiki free for you.

  6. #6
    Join Date
    Jul 2008
    Posts
    1

    Default

    I am having the same issue and unsure of where to go. Please assist.

  7. #7

    Default A solution

    Hello,
    I had exactly the same problem and it's been solved by :
    1) Launching EasyPHP
    2) Creating a database and a user in PHPmyadmin (navigator : http://localhost/home/mysql/)
    3) Entering in the mediawiki installation the same database and user & password than in PHPmyadmin.
    Installation successful!

Similar Threads

  1. Locate subdomain username
    By thenewbreed in forum General Joomla Discussions
    Replies: 1
    Last Post: 06-03-2009, 01:08 PM
  2. Joomla 1.0.15: Incorrect username or password
    By parish in forum General Joomla Discussions
    Replies: 0
    Last Post: 08-10-2008, 07:02 AM
  3. Backing up and moving a MediaWiki database
    By paradox in forum Other Software and Applications
    Replies: 1
    Last Post: 01-16-2007, 03:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •