Web Hosting
Results 1 to 12 of 12
  1. #1

    Default $_POST is not Working help me please

    when i uploaded first my files to siteground to my login $_POST was worked with all files, but once i changed the code below in one of my file $_POST is not working on any file why?

    "form enctype="multipart/form-data" name="form1" action="mail.php" method="POST" "
    "input type="hidden" name="MAX_FILE_SIZE" value="10485760000" "

    Please help me Thanks well in advance!!!

  2. #2
    Dan Guest

    Default

    Could you please let us know the exact location of the file you have experienced on your account with us and also the domain name it is hosted with.

  3. #3

    Default Hi Dan

    Domain Name:www.acodez.com
    My Application Path : www.acodez.com/knapsack

    My File Location is:/Pulic_html/Knapsack/

    files are: 1. userlogin.php to send the values of an user to authenticate it with logincheck.php file.

    I m having more tahn twenty files which uses POST Method in the form action to send a valus to next file and i m using $_post to receive the value, so plaese help me why $_POST is not working, but when i replace it all with GET its works fine please let me know a solution.

    Thanks Well in ADvance.

    Regards

    Karthikeyan.K

  4. #4

    Default

    "input type="hidden" name="MAX_FILE_SIZE" value="10485760000" "



    Get rid of that seccond quote there, you dont need it I dont think...

  5. #5
    Join Date
    Apr 2007
    Location
    Plovdiv, Bulgaria
    Posts
    52

    Default

    In order to troubleshoot the issue, could you please rename the original mail.php file to something else and create a new one by using the following code:

    <?php print_r($_POST); ?>

    It should print the whole $_POST array.. if the array is empty, I would like to ask you to post a ticket by using your customer area, as there should be something wrong.

    Generally, the $_POST, $GET, $REQUEST, $_GLOBALS, $_SERVER, $_COOKIE, $_FILES, $_SESSION and $_ENV were defined as superglobals in PHP 4.1.0. Since we do not support PHP versions less than 4.2, if your script is properly working, there has to be a server side issue which should be checked.

  6. #6

    Default Thanks to NikolaP

    Hi

    i forgot to give the important details, i m having two folders in my domain, each folder contains php files. In the first folder i m having two files one file sends the value entered in the textfield to the second file using POST method there it works fine.

    But in the second folder(this the folder where i m having problem) has the two files as the same as first folder, here the POST method is not working.

    As u told i tried with the code

    php print_r($_POST);

    in both the folder i had used the code given by you, in the first folder it works fine that is it returned the values for POST array, but for the second folder code is not working.
    it returned an empty array as follws: Array( );

    What may be the problem why because when i use GET in both folder it works fine yar?

    Thanks well in advance.

  7. #7
    Join Date
    Apr 2007
    Location
    Plovdiv, Bulgaria
    Posts
    52

    Default

    I am sorry for the delayed answer, I haven't been in the forum for a few days now.

    Well, it seems there is an issue with the $_POST superglobal and I am afraid that given the information provided here I am unable to inform you what is the reason for that.

    Please consider renaming the files to .sphp extension and providing a URL to them, so I could check the exact source code being used.

  8. #8

    Default to NikolaP

    hi
    u asked me to rename the files to .sphp and give it to them means to whom shall i give?

    Regards
    Karthikeyan.K

  9. #9
    Join Date
    Apr 2007
    Location
    Plovdiv, Bulgaria
    Posts
    52

    Default

    Well, I guess that you should post the links to this thread

    However, I am currently in the office, so if you post a ticket I will be able to check the case deeply and inform you what is wrong, so please consider that option as well.

  10. #10

    Default to NikolaP

    hi
    sorry for delay.
    can u tell me in which part of help desk shall i post my ticket so that u can receive, such as cpanel problem or web site is not accesible or etc.. please provide me the correct place to put my ticket.
    regards
    Karthikeyan.K

  11. #11

    Default Hi NikolaP

    hi
    i had posted a ticket i got the following reply from helpdesk, can u tell me any idea which can help me to overcome this problem.

    Reply From Helpdesk of siteground Team member:

    Your request is beyond the scope of our hosting-related support. It is not directly connected to a server-side issue and does not indicate a problem with the hosting service we offer.

    Please contact a local web developer who will be able to assist you with your issue.

    You can also try to find more information by searching in google. Our experience shows you can find answers to literary every question in Google.

    Thank you for your understanding of our efforts to provide better and more effective support.

    Best Regards,

    Dimo
    Senior Support Team
    SiteGround.com

  12. #12
    Join Date
    Apr 2007
    Location
    Plovdiv, Bulgaria
    Posts
    52

    Default

    Well, I have just tested your account by using a php file with the following lines within:

    <form method=post action="1.php"><input type=text value=1 name=set><input type=submit></form>
    <?php if ($_REQUEST["set"] == "1") { print_r($_REQUEST); } ?>

    It seems that there is a problem with the POST requests, however, the GET ones appears to be properly working. I will check the issue in depth and will provide you with an update soon. I guess that mod_security is causing the troubles..

Similar Threads

  1. SEF not working
    By Run4it in forum General Joomla Discussions
    Replies: 13
    Last Post: 09-19-2011, 01:25 PM
  2. not working for me ... at all :(
    By 0--0 in forum Customers' experience and suggestions
    Replies: 12
    Last Post: 06-08-2010, 08:04 AM
  3. Template not working at all
    By Nourf in forum Free Joomla Templates
    Replies: 1
    Last Post: 12-08-2008, 07:45 AM
  4. ftp changes not working
    By andyahoo in forum General Joomla Discussions
    Replies: 1
    Last Post: 02-20-2006, 12:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •