Web Hosting
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2008

    Default Silverstripe install error


    I just recently went through a painfulll silverstripe install and wanted to give some feedback. This error occurs on mo_rewrite test but is not caused by mod_rewrite, your siteground account should be set up for mod rewrite. The following link has simple code for testing mod_rewrite http://www.wallpaperama.com/forums/h...abled-t40.html

    To fix the error on a standard install on siteground simply follow the instructions below. Hope this saves somebody some time.

    ***** silversripe httprespond installin Error on Siteground *******

    - reason, silverstripe uses a HttpReference class that is already being called by php
    - also causes mod_rewrite test to fail

    1) Open your copy new of the silverstripe install files.
    2) Go to "sapphire/core/control/HTTPResponse.php" and rename it to "sapphire/core/control/SSHTTPResponse.php "
    3) Open the new SSHTTPResponse.php and edit the HTTPResponse class to read SSHTTPResponse. Look through the file and change any other references to HTTPResponse to SSHTTPResponse.
    4) Open the following files and change all references to the HTTPResponse to SSHTTPResponse.:
    - sapphire/core/control/ContentNegotiator.php
    - sapphire/core/control/Director.php
    - sapphire/core/control/Controller.php
    - sapphire/forms/Form.php

    Save and upload all the files to their respective directories and run the silverstripe install.

    ************** Enjoy*************

  2. #2
    Join Date
    Jun 2005

    Default SSHTPResponse

    I,ve done what has been recommended but it still doesn't work.


  3. #3
    Join Date
    Oct 2008


    I have checked your account and found some files, where there were still references to the HTTPResponse function:


    You will need to modify these files also in order to make your SilverStripe application operational.
    Best Regards,
    SiteGround Technical Support Team
    Siteground Web Hosting

    Join us on Facebook
    Follow us on Twitter

  4. #4
    Join Date
    Jun 2005



    Thanks Centry01 for your hint.

    Originally it did not worked for me - I was getting
    "HttpRequest::__construct() expects at most 3 parameters, 5 given" error when istall finished.
    Then after pulling out the remaining of my hair I've finally succeeded.

    There were two issues:
    1. With Silverstripe 3.2.1 here were more files referencing to HTTPResponse
    2. HTTPRequest also needed to be changes to something else. I used the same scheme and renamed it to SSHTTPRequest.

    Here is how.
    On my Ubuntu machine I've unarchived the Silverstripe distribution and then run

    for f in `rgrep -l HTTPResponse SilverStripe-v2.3.1` do; perl -pi -e 's/HTTPResponse/SSHTTPResponse/g' $f; done
    for f in `rgrep -l HTTPResponse SilverStripe-v2.3.1` do; perl -pi -e 's/HTTPRequest/SSHTTPRequest/g' $f; done

    (Sorry translating the above from zsh to bash, hope the semicolons are in the right places :-)
    Then I renamed sapphire/core/control/HTTPResponse.php -> sapphire/core/control/SSHTTPResponse.php and sapphire/core/control/HTTPRequest.php -> sapphire/core/control/SSHTTPRequest.php

    Created archive, apploaded it to the SiteGround, put
    "AddHandler application/x-httpd-php52 .php .php5 .php4 .php3" to .htaccess and it worked!

    Happy, happy..

    PS. Just realised that I should've done "rgrep -l HTTPRequest SilverStripe-v2.3.1" in the second command, but so far so good.

Similar Threads

  1. install error for vbulletin
    By rockinrobots in forum Forum Applications
    Replies: 5
    Last Post: 09-14-2009, 12:02 AM
  2. webERP install error
    By zfhtang in forum Other Software and Applications
    Replies: 12
    Last Post: 07-02-2009, 09:03 PM
  3. Is anyone running SilverStripe?
    By djhall in forum Other Software and Applications
    Replies: 13
    Last Post: 09-03-2008, 08:03 PM
  4. 1.5RC4 install error
    By twoten in forum General Joomla Discussions
    Replies: 2
    Last Post: 12-27-2007, 09:56 AM
  5. Error in Install
    By amorgad in forum General Joomla Discussions
    Replies: 2
    Last Post: 08-20-2007, 08:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts